Monday, November 3, 2014

one or more required office components failed to complete successfully



one or more required office components failed to complete successfully

issue: Unable to un-install the SharePoint 2013 on the server. Shows the error one or more required office components failed to complete successfully.

Solution: The issue could be of many reasons. In this article I am putting the solutions together to resolve the issue.

Solutions 1:Go to the services, find the Sql server services Stop them as follows and then uninstall the SharePoint server 2013 will be uninstalled successfully.

1.    SQL Full-text filter Daemon launcher (MSSQLSERVER)
2.    Sql server(MSSQLSERVER)
3.    Sql server agent(MSSQLSERVER)
4.    Sql server Analysis services(MSSQLSERVER)

Whenever you are re installing the SharePoint server again restart all the services or required only

Solution 2: Ensure the Site is available in the IIS as configured while installing the SharePoint by default.

Solution 3: Ensure that the UAC is turn on in the server.

Solution 4:  which already has SharePoint Designer 32 bit version installed – thus appropriate version of Office Suite is 32 bit as you can’t mix versions of Office Components. Then you probably installed SharePoint 2010 Foundation 64 bit version. And here the problem is – you have 32 bit Office Components and 64 bit SharePoint 2010 Foundation

Ensure that the versions should be same.
 


I hope the above information will help you to resolve the issue, in case of any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

Installing and Configuring Workflow Manager 1.0



Installing and Configuring Workflow Manager 1.0


A very good article from MS that shows on how to deploy and configure the workflow manager 1.0.


 

I hope the above information will help you to resolve the issue, in case of any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

Installation Required and Upgrade Blocked



Installation Required  and Upgrade Blocked

I am getting more Queries from SharePoint community about the below, so explaining in this article.

Definition: when we Install the CU in the farm, we see the Installation required and upgrade blocked in the status of servers under the system settings in CA.

Installation Required : The server still not yet install with the same CU that already installed in other servers.

Upgrade Blocked : The server is blocked from upgrade. current Server is installed with latest CU and it will remained blocked until all the SP servers in the farm are installed with the same version.
 

I hope the above information will help you to resolve the issue, in case of any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

Sticky sessions



Sticky sessions:

This is a general topic about the requests from users when they access the sites. I am getting more Queries from SharePoint community so explaining in this article.

Definition: If you have multiple front-end servers a sticky session ensures that every request of a client gets redirected to the same server instead of all requests of a single client divided over multiple servers. This makes handling session state easier, as you'll only have to store it in memory if you have sticky sessions. Otherwise, you'll have to have a central store that is accessed by all front-ends. The stick session feature is comes up with the LB not the share point. It should be  configure in the LB.
 


I hope the above information will help you to resolve the issue, in case of any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

Your backup is from a different version of Microsoft SharePoint" - Error while restoring the site



Your backup is from a different version of Microsoft SharePoint" - Error while restoring the site

Error: Restore-SPSite: Your backup is from a different version of Microsoft SharePoint Foundation and cannot be restored to a server running the current version. The backup file should be restored to a server with version '4.2.7.0' or later.

Resolution: First check the patch level of  your source and destination environment. Make sure your destination environment is not at lower version than the source. If so , you may need to patch your environment as same as your source.

Steps to Check Database Schema Versions :

Central Administration application Management à Manage content databases Select your database where you want to restore click on the DB name à  under “Database Versioning and Upgrade” you can see something like below

Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence Current Schema Version: 4.1.30.0, Maximum Schema Version: 4.2.7.0
Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence2 Current Schema Version: 4.1.7.0, Maximum Schema Version: 4.1.7.0
Microsoft.SharePoint.Administration.SPContentDatabase Current Schema Version: 14.0.6137.5002, Maximum Schema Version: 14.0.7105.5000

If the Current Schema Version is less than the Maximum Schema Version, then the database should be upgraded as soon as possible.

To Upgrade content database, Execute the below command in powershell.

Upgrade-SPContentDatabase <Content_db_name>”

After executing the command,

Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence Current Schema Version: 4.2.7.0, Maximum Schema Version: 4.2.7.0
Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence2 Current Schema Version: 4.1.7.0, Maximum Schema Version: 4.1.7.0
Microsoft.SharePoint.Administration.SPContentDatabase Current Schema Version: 14.0.7105.5000, Maximum Schema Version: 14.0.7105.5000

Now the database is upgrade to the version 4.2.7.0 and you can restore without any issues.

 


I hope the above information will help you to resolve the issue, in case of any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.
Related Posts Plugin for WordPress, Blogger...

ShareThis

X